We’re pleased to share that the code updates addressing rendering issues for Safari version 16.3 and earlier have been successfully deployed to production and validated. All functionality is now working as expected. We will continue to monitor system performance and user reports closely. While this fix addresses the recent compatibility issues, we strongly recommend keeping browsers up to date to ensure access to the latest security patches and performance enhancements. Thank you for your patience and understanding.
Posted Apr 14, 2025 - 12:31 EDT
Identified
The Engineering team has implemented code changes to support Safari version 16.3 and earlier. These updates are scheduled to go live in production on April 14. While this should address the current rendering issues, we strongly recommend that clients keep their browsers up to date to benefit from the latest security patches and performance improvements.
Posted Apr 10, 2025 - 05:35 EDT
Investigating
We have received reports of issues loading Blackboard for Safari 16.3 and earlier users following the 3900.114.0 release. We recommend that impacted users upgrade to Safari 16.4 or later, available with iOS 16.4 or iPadOS 16.4.
Anthology's browser support policy for Safari states that we only support the last two major releases of Safari. We always recommend that clients update to the latest available versions when made available for the latest security fixes for their devices.
Posted Apr 09, 2025 - 11:11 EDT
This incident affected: Africa (Blackboard - SaaS (Africa)), Asia Pacific (Blackboard - SaaS (Asia Pacific)), Europe & Middle East (Blackboard - SaaS (Europe)), Global (Blackboard - SaaS - Global), and Americas (Blackboard - SaaS (US), Blackboard – SaaS Gov Cloud (US)).