Blackboard SaaS LMS Outage - Global

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 08:57 EDT

Monitoring

AWS has implemented a fix for the underlying issue. We are observing signs of recovery, and service appears to be stable at this time. We will continue monitoring the environment and provide updates if necessary.
Posted Jul 16, 2026 - 07:24 EDT

Update

AWS continues to work on mitigation efforts, and our teams remain actively engaged and closely coordinating with them. We continue to monitor the environment and provide updates as progress is made.
Posted Jul 16, 2026 - 06:25 EDT

Update

We have identified the issue impacting a subset of customers. AWS has confirmed the issue and is actively working on mitigation efforts to reduce the impact.
Our teams are closely monitoring the situation, coordinating with AWS, and working toward full recovery. We will continue to provide updates as more information becomes available.
Posted Jul 16, 2026 - 05:40 EDT

Identified

We have identified the issue as being related to AWS CloudFront. We are actively working with AWS to restore service as quickly as possible.
Our team is closely monitoring the situation and will provide further updates as soon as additional information becomes available.
Posted Jul 16, 2026 - 04:51 EDT

Investigating

We are currently investigating an issue affecting the production environment for multiple clients.
Posted Jul 16, 2026 - 04:33 EDT
This incident affected: Global (Blackboard - SaaS - Global).