Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 14, 2025 - 08:00 EDT
Scheduled
Anthology will be deploying a an off-cycle Blackboard SaaS 3900.114.0 Maintenance Release to Production environments due to changes required to support Safari version 16.3 and earlier. This will be an Ultra UI only change so all sites will be updated in a shorter timeframe and the full build number will not change.
While this should address the current rendering issues, we strongly recommend that clients keep their browsers up to date to benefit from the latest security patches and performance improvements.
Scheduled for April 14, 2025
Posted Apr 11, 2025 - 09:46 EDT
This scheduled maintenance affected: Africa (Blackboard - SaaS (Africa)), Asia Pacific (Blackboard - SaaS (Asia Pacific)), Europe & Middle East (Blackboard - SaaS (Europe)), and Americas (Blackboard - SaaS (US), Blackboard – SaaS Gov Cloud (US)).