SafeAssign Maintenance – TP/Stage (February 12)

Scheduled for Feb 12, 09:00 - 13:00 EST

Update

The SafeAssign maintenance window has been moved to February 12.
Posted Feb 05, 2026 - 07:24 EST

Scheduled

Please be advised of a scheduled maintenance window for the SafeAssign TP/Stage environment. Customers will experience temporary service unavailability during this window. This maintenance is part of ongoing platform improvements. No data loss is expected.

Date/Time: Thursday, Feb 12th at 9:00 AM EST (2:00 PM UTC)
Duration: approximately 4 hours
Posted Feb 05, 2026 - 07:30 EST
This scheduled maintenance affects: Africa (Blackboard - SaaS (Africa)), Americas (Blackboard - SaaS (US), Blackboard – SaaS Gov Cloud (US)), Asia Pacific (Blackboard - SaaS (Asia Pacific)), and Europe & Middle East (Blackboard - SaaS (Europe)).