Blackboard - Course Catalog Performance isssue- EU region

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved, and it was observed that course catalog services are operating normally.
Posted Oct 10, 2025 - 10:41 EDT

Monitoring

Our engineers have deployed a fix and are monitoring the system performance.
Posted Oct 06, 2025 - 23:47 EDT

Investigating

We are currently experiencing some issues in the EU region that is impacting catalog services. Our teams are currently investigating this.
Posted Oct 03, 2025 - 18:20 EDT
This incident affected: Europe & Middle East (Blackboard - Course Catalog).