Course Catalog Maintenance

Incident Report for Blackboard Inc.

Resolved

Maintenance is complete. Payments with Flywire in Asia-pacific are now available.
Posted Apr 08, 2026 - 16:39 EDT

Identified

Due to some maintenance work on our payment infrastructure, payments with Flywire in Asia-Pacific are unavailable.
Posted Apr 08, 2026 - 16:15 EDT
This incident affected: Asia Pacific (Blackboard - Course Catalog).