Illuminate - Performance Degradation Impacting Snowflake Queries and Reports

Incident Report for Blackboard Inc.

Resolved

The performance issue has been resolved. Snowflake queries and Illuminate reports are now operating normally
Posted Apr 16, 2026 - 06:08 EDT

Monitoring

We have identified the root cause of the issue and deployed a fix to production. The team is closely monitoring performance to ensure stability
Posted Apr 16, 2026 - 05:19 EDT

Investigating

We are currently experiencing performance degradation. As a result, some Snowflake queries may run slower than usual, and Illuminate reports may take longer to load or could time out. Our team is actively investigating the issue and working to restore normal performance at the earliest
Posted Apr 16, 2026 - 03:37 EDT
This incident affected: Global (Illuminate).