Course Catalog Outage - US-East & AF Regions

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 17:05 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2025 - 08:34 EST

Investigating

We are currently experiencing an outage affecting Certificate and Progress components within the Course Catalog in the US-East & AF regions. Our engineering team is actively working to resolve the issue.
Posted Nov 18, 2025 - 16:39 EST
This incident affected: Africa (Blackboard - Course Catalog) and Americas (Blackboard - Course Catalog).