Anthology Illuminate: Data Q&A currently unavailable

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 12:49 EDT

Identified

We have identified it as a problem with our technology provider, and we are working with them. We will keep you updated as soon as we have more information and a timeline.
Posted Sep 05, 2025 - 10:06 EDT

Investigating

We are currently experiencing issues with Data Q&A across all regions. This feature is currently not functioning, and this issue manifests as the tool appearing to be “loading” indefinitely. Our team is actively investigating and working to resolve the issue and restore full functionality. We appreciate your patience and apologize for any inconvenience this may cause.
Posted Sep 05, 2025 - 06:55 EDT
This incident affected: Global (Anthology Illuminate).