Blackboard-Course Catalog down - US & AF regions.

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 12:05 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2025 - 11:21 EDT

Identified

The cause of the issue has been identified. Teams are working to implement a fix.
Posted Sep 10, 2025 - 10:52 EDT

Update

We are continuing to investigate this issue.
Posted Sep 10, 2025 - 09:54 EDT

Investigating

Our monitoring has detected that Course Catalog is down for US-EAST region. Teams are investigating to fix the issue.
Posted Sep 10, 2025 - 09:14 EDT
This incident affected: Africa (Blackboard - Course Catalog) and Americas (Blackboard - Course Catalog).