Ally Processing Delays - US-east Region (November 18, 2025)

Incident Report for Blackboard Inc.

Resolved

After continued monitoring we've seen processing return to normal levels.
Posted Nov 20, 2025 - 08:52 EST

Monitoring

Realtime queues are once again approaching normal levels and the team continues to monitor processing and reporting updates.
Posted Nov 19, 2025 - 13:43 EST

Identified

Notice for US Ally Deployments – there has been an increase in traffic in the last 24 hours (November 18) impacting Ally's bulk, realtime, reporting and surge processing queues resulting in slower processing times.

Ally and its associated components remain available, however there may be delays in processing some of these updates. Real time processing for new content items will be delayed along with report updates. Ally engineering and development teams continue to work on this as a high priority and will provide updates as processing levels return to normal.
Posted Nov 18, 2025 - 14:39 EST
This incident affected: Americas (Ally - North America).